МОУ

"Средняя общеобразовательная

школа №9"

г. Таштагол

Оператор выбора Case

Подпись: Пример: С клавиатуры ввести число и определить день недели (если первое число месяца понедельник)


wrclub.net

МОУ

школа №9"

г. Таштагол

Графика в Паскале

Основы программирования на языке Pascal

Язык программирования Паскаль был разработан Никлаусом Виртом в конце 60-х -начале 70-х годов для обучения студентов программированию

Первые программы (40-ые годы XX века) писались на языке машинных кодов из 0 и 1. Эти программы были машиннозависимыми.

В 50-е годы ХХ века появились программы, называемые ассемблерами, в которых программа записывается с помощью боле понятных человеку слов и символов. Для перевода с ассемблера на машинный язык использовался компилятор.

Языки близкие к процессору называются языками низкого уровня, а языки удобные для людей- высокого уровня (Fortran, Cobol, Lisp, Basic, Pascal,

Все языки программирования делятся на: процедурные (Fortran, Pascal, Basic, C), объектно-ориентированные(C++, JAVA) и логические(Лисп, Пролог).

В процедурных языках работа программ рассматривается как последовательное выполнение операторов.

В объектно-ориентированных языках работа программы рассматривается как последовательность событий и соответствующих реакций различных объектов на эти события.

В логических языках работа программы рассматривается как преобразование в соответствии со строгими логическими правилами.


школа №9"

г. Таштагол

Графика в Паскале

В составе Турбо Паскаля есть специальный графический модуль Graph, который содержит графические процедуры:

Putpixel (x, y, c,) – рисует точку с координатами x, y, цветом c;

Line (x1, y1, x2, y2) – рисует линию от точки с координатами x1, y1, до точки с

координатами x2, y2;

Rectangle (x1, y1, x2, y2) – рисует рамку, с диагональю x1, y1 – x2, y2

Bar (x1, y1, x2, y2) – рисует прямоугольник с диагональю x1, y1 – x2, y2, закрашенный

в соответствии с образцом, установленным процедурой Setfillstile;

Bar3d (x1, y1, x2, y2, h, top [on/off]) – рисуется прямоугольный брусок, с передней

гранью на диагонали x1, y1 – x2, y2, глубиной, обусловленной параметром h. Параметр top

определяет будет ли у бруска перекрытие сверху.

Arc (x, y, alf1, alf2, r) – рисуется дуга радиуса r с центром в точке x, y от угла alf1 до

угла alf2. Угол задается в градусах;

Circle (x, y, r) – рисуется окружность радиуса r, с центром в точке x, y;

Setlinestile (stil, pattern, tolsch) – Устанавливает тип линии и ее толщину;

Константы типа линий (stil) и их толщины (toisch)

Константа | Значение
SolidLn DottedLn CenterLn DashedLn | 0 – сплошная линия 1 – точечная линия 2 – штрихпунктирная линия 3 – пунктирная линия
NormWidth ThickWidth | 1 – нормальная толщина линии 3 – жирная линия

Setfillstile (orb, c) – устанавливает образец заполнения для процедур Bar, Bar3d,

Floodfill. Где orb – параметр закраски, с – цвет.

Константы закраски (orb)

Константа | Значение
EmptyFill SolidFill LineFill ItSlashFill SlashFill BkSlashFill LtBkSlashFill HatchFill XHatchFill InterleaveFill WideDotFill CloseDotFill UserFill | 0 - Закраска области фоновым цветом 1 - Сплошная закраска области 2 - Закраска линиями ------------ 3 - Закраска линиями / / / / / / / / 4 - Закраска жирными линиями / / / / / / / / 5 - Закраска жирными линиями \ \ \ \ \ \ \ \ 6 - Закраска линиями \ \ \ \ \ \ \ 7 - Закраска редкой штриховкой 8 - Закраска частой штриховкой 9 - Закраска прерывистой линией 10 - Закраска линией из редких точек 11 - Закраска линией из частых точек 12 - Закраска определяется программистом

Константы цвета (c)

Константа | Значение
Black Blue Green Cyan Red Magenta Brown LightGray DarkGray LightBlue LightGreen LightCyan LightRed LightMagenta Yellow White Blink | 0 (Черный) 1 (Синий) 2 (Зеленый) 3 (Бирюзовый) 4 (Красный) 5 (Малиновый) 6 (Коричневый) 7 (Светло-серый) 8 (Темно-серый) 9 (Светло-синий) 10 (Светло-зеленый) 11 (Светло-бирюзовый) 12 (Светло-красный) 13 (Светло-малиновый) 14 (Желтый) 15 (Белый) 128 (Мерцание)

Setcolor (c) – устанавливает цвет рисования;

Setbkcolor(c) – устанавливает цвет фона;

Floodfill (x, y, c) – Заполняет замкнутые области, ограниченные линией цвета с, в

соответствии с образцом, установленным процедурой Setfillstile. Координаты х, у должны

лежать внутри заполняемой области.


школа №9"

г. Таштагол

Отличие двумерных массивов от линейных состоит в том, что элементы массива (компоненты) имеют два индекса, которые указывают положение элемента в массиве и служат идентификатором при поиске элементов.

Элемент массива описывается как а[i,j], где i-показывает строку, в которой расположен элемент, j- место этого элемента в строке (столбец).

Для ввода матрицы в память существует много способов, это зависит от направления задачи. Рассмотрим два самых распространенных способа:

Пример 1 (ввод с клавиатуры)

Writeln(‘Введите элементы матрицы по строкам’);

Writeln(‘В конце каждой строки нажимайте  ENTER’);

    For i:=1 to n do begin

      For j:= 1 to m do Readln(a[i,j]);

      end;

       End.

Пример 2. Заполнение случайными числами

{заполнение массива}

For i:=1 to n do begin

     For j:=1 to m do

     a[i,j]:=random(10);

     end;

{вывод массива на экран}

   For i:=1 to n do begin

     For j:=1 to m do

     write(a[i,j]:8);

     writeln;

     end;

End.

Задачи

Вычисление:

а) суммы элементов квадратной матрицы;

б) суммы элементов главной диагонали квадратной матрицы;

Program Summa;

  const n=7;

var  a:array [1..n,1..n] of integer; i,j,S,S1: integer;

Begin

 For i:=1 to n do begin

   For j:=1 to n do

   a[i,j]:=random(100) - 50;

   end;

For i:=1 to n do begin

   For j:=1 to n do

   write(a[i,j]:8);

   writeln;

   end;

{вычисление суммы всех элементов квадратной матрицы}

S:=0;

 For i:=1 to n do begin

   For j:=1 to n do

   S:=S+a[i,j];

   end;

writeln(‘сумма всех элементов S=‘,S);

{суммы элементов главной диагонали квадратной матрицы}

S1:=0;

 For i:=1 to n do begin

   For j:=1 to n do

   If i=j then S:=S+a[I,j];

   end;

   writeln (‘сумма главной диагонали =‘, S1);

End.

Результат выполнения программы:


школа №9"

г. Таштагол

Графика в Паскале

Инициализация графического режима

Program Inicializacija;

Uses graph;

Var

Graphdriver, {Графический драйвер}

Graphmode: Integer; {Графический режим}

Begin

Graphdriver:= Detect; {автораспознавание драйвера}

Initgraph (Graphdriver, grathmode, ‘ <путь к дрфйверу> ’);

……. {графические действия}…….

Readln;

Closegraph;

End.


школа №9"

г. Таштагол

Решение квадратного уравнения

Программа для нахождения корней квадратного уравнения


школа №9"

г. Таштагол

Операции с файлами

3.Подготовка к записи в файл Паскаля

     Rewrite(<имя_ф_переменной>);

Процедура Rewrite(f) (где f – имя файловой переменной) устанавливает файл с именем f в начальное состояние режима записи, в результате чего указатель устанавливается на первую позицию файла. Если ранее в этот файл были записаны какие-либо элементы, то они становятся недоступными. Результат выполнения процедуры rewrite(f); выглядит следующим образом:

файл Паскаля (Pascal)

4.Запись в файл Паскаля

     Write(<имя_ф_переменной>, <список записи>);

При выполнении процедуры write(f, x) в ту позицию, на которую показывает указатель, записывается очередная компонента, после чего указатель смещается на следующую позицию. Естественно, тип выражения х должен совпадать с типом компонент файла. Результат действия процедуры write(f, x) можно изобразить так:

Состояние файла f до выполнения процедуры

файл Паскаля (Pascal)

Состояние файла f после выполнения процедуры

файл Паскаля (Pascal)

Для типизированных файлов выполняется следующее утверждение: если в списке записи перечислено несколько выражений, то они записываются в файл, начиная с первой доступной позиции, а указатель смещается на число позиций, равное числу записываемых выражений.

5.Подготовка файла к чтению Паскаля

     Reset(<имя_ф_переменной>);

Эта процедура ищет на диске уже существующий файл и переводит его в режим чтения, устанавливая указатель на первую позицию файла. Результат выполнения этой процедуры можно изобразить следующим образом:

файл Паскаля (Pascal)

Если происходит попытка открыть для чтения не существующий еще на диске файл, то возникает ошибка ввода/вывода, и выполнение программы будет прервано.

6.Чтение из файла в Паскале

     Read(<имя_ф_переменной>,<список переменных>);

Pассмотрим результат действия процедуры read(f, v):

Состояние файла f и переменной v до выполнения процедуры:

файл Паскаля (Pascal)

Состояние файла f и переменной v после выполнения процедуры:

файл Паскаля (Pascal)

Переменная v в данном примере это виртуальная память паскаля ориентированная на запись последовательностей из файла.

Для типизированных файлов при выполнении процедуры read() последовательно считывается, начиная с текущей позиции указателя, число компонент файла, соответствующее числу переменных в списке, а указатель смещается на это число позиций.

В большинстве задач, в которых используются файлы, необходимо последовательно перебрать компоненты и произвести их обработку. В таком случае необходимо иметь возможность определять, указывает ли указатель на какую-то компоненту файла, или он уже вышел за пределы файла и указывает на маркер конца файла.


школа №9"

г. Таштагол

Операции с ФП

7.Функция определения достижения конца файла в Паскале

Eof(<имя_ф_переменной>);

Название этой функции является сложносокращенным словом от end of file. Значение этой функции имеет значение true, если конец файла уже достигнут, т.е. указатель стоит на позиции, следующей за последней компонентой файла. В противном случае значение функции – false.

8.Изменение имени файла в Паскале

Rename(<имя_ф_переменной>, <новое_имя_файла>);

Здесь новое_ имя_ файла – строковое выражение, содержащее новое имя файла, возможно с указанием пути доступа к нему.

Перед выполнением этой процедуры необходимо закрыть файл, если он ранее был открыт.

9.Уничтожение файла в Паскале

Erase(<имя_ф_переменной>);

Перед выполнением этой процедуры необходимо закрыть файл, если он ранее был открыт.

10.Уничтожение части файла от текущей позиции указателя до конца в Паскале

Truncate(<имя_ф_переменной>);

11.Файл Паскаля может быть открыт для добавления записей в конец файла

Append(<имя_ф_переменной>);

Типизированные файлы Паскаля. Длина любого компонента типизированного файла строго постоянна, т.к. тип компонент определяется при описании, а, следовательно, определяется объем памяти, отводимый под каждую компоненту. Это дает возможность организовать прямой доступ к каждой компоненте (т.е. доступ по порядковому номеру).

Перед первым обращением к процедурам ввода/вывода указатель файла стоит в его начале и указывает на его первый компонент с номером 0. После каждого чтения или записи указатель сдвигается к следующему компоненту файла. Переменные и выражения в списках ввода и вывода в процедурах read() и write() должны иметь тот же тип, что и компоненты файла Паскаля. Если этих переменных или выражений в списке несколько, то указатель будет смещаться после каждой операции обмена данными на соответствующее число позиций.

Для облегчения перемещения указателя по файлу и доступа к компонентам типизированного файла существуют специальные процедуры и функции:

fileSize(<имя_ф_переменной>) – функция Паскаля, определяющая число компонентов в файле;

filePos(<имя_ф_переменной>) – функция Паскаля, значением которой является текущая позиция указателя;

seek(<имя_ф_переменной>,n) – процедура Паскаля, смещающая указатель на компоненту файла с номером n. Так, процедура seek(<имя_ф_переменной>,0) установит указатель в начало файла, а процедура seek(<имя_ф_переменной>, FileSize(<имя_ф_переменной>)) установит указатель на признак конца файла.

Текстовые файлы Паскаля. Текстовые файлы предназначены для хранения текстовой информации. Именно в таких файлах хранятся, например, исходные тексты программ. Компоненты текстовых файлов могут иметь переменную длину, что существенно влияет на характер работы с ними. Доступ к каждой строке текстового файла Паскаля возможен лишь последовательно, начиная с первой. К текстовым файлам применимы процедуры assign, reset, rewrite, read, write и функция eof. Процедуры и функции seek, filepos, filesize к ним не применяются. При создании текстового файла в конце каждой записи (строки) ставится специальный признак EOLN(end of line – конец строки). Для определения достижения конца строки существует одноименная логическая функция EOLN(<имя_ф_переменной>), которая принимает значение true, если конец строки достигнут.

Форма обращения к процедурам write и read для текстовых и типизированных файлов одинакова, но их использование принципиально различается.

В списке записываемых в текстовый файл элементов могут чередоваться в произвольном порядке числовые, символьные, строковые выражения. При этом строковые и символьные элементы записываются непосредственно, а числовые из машинной формы автоматически преобразуются в строку символов.

· текстовые файлы удобнее для восприятия человеком, а типизированные соответствуют машинному представлению объектов;

· текстовые файлы, как правило, длиннее типизированных;

· длина текстовых файлов зависит не только от количества записей, но и от величины переменных.

Так, в типизированном файле числа 6, 65 и 165 как целые будут представлены одним и тем же числом байт. А в текстовых файлах, после преобразования в строку, они будут иметь разную длину. Это вызывает проблемы при расшифровке текстовых файлов. Пусть в текстовый файл пишутся подряд целые числа (типа byte): 2, 12, 2, 128. Тогда в файле образуется запись 2122128. При попытке прочитать из такого файла переменную типа byte программа прочитает всю строку и выдаст сообщение об ошибке, связанной с переполнением диапазона.

Но, вообще-то, такой файл не понимает не только машина, а и человек.

Чтобы избежать этой ошибки, достаточно вставить при записи в файл после каждой переменной пробел. Тогда программа при каждом чтении берет символы от пробела до пробела и правильно преобразует текстовое представление в число.

Кроме процедур read и write при работе с текстовыми файлами используются их разновидности readln и writeln. Отличие заключается в том, что процедура writeln после записи заданного списка записывает в файл специальный маркер конца строки. Этот признак воспринимается как переход к новой строке. Процедура readln после считывания заданного списка ищет в файле следующий признак конца строки и подготавливается к чтению с начала следующей строки.

Пример решения задачи с файлами Паскаля

Пусть нам необходимо сформировать текстовый файл с помощью Паскаля, а затем переписать из данного файла во второй только те строки, которые начинаются с буквы «А» или «а».

Пояснения: нам понадобятся две файловые переменные f1 и f2, поскольку оба файла текстовые, то тип переменных будет text. Задача разбивается на два этапа: первый – формирование первого файла; второй – чтение первого файла и формирование второго.

Для завершенности решения задачи есть смысл добавить еще одну часть, которая в задаче явно не указана – вывод на экран содержимого второго файла.

<-Назад


школа №9"

г. Таштагол

Физические файлы на дисках и переменные файлового типа в Паскале – объекты различные. Переменные файлового типа могут соответствовать не только физическим файлам, но и логическим устройствам, связанным с вводом/выводом информации. Например, клавиатуре и экрану соответствуют файлы со стандартными именами Input, Output.

По причине неспособности Паскаля производить операции непосредственно с файловыми переменными все операции могут производиться лишь с элементами (компонентами) файлов. Естественно, что множество операций над компонентами файла определяется типом компонент.

Если путь к файлу не указан, то программа будет искать его в своем рабочем каталоге и по указанным путям в autoexec.bat.

Вместо имени дискового файла можно указать имя логического устройства, каждое из которых имеет стандартное имя:

Имя | Значение
CON PRN INPUT OUTPUT | консоль, т.е. клавиатура-дисплей принтер (если принтеров несколько, то доступ к ним осуществляется по именам LPT1, LPT2, LPT3… Клавиатура Монитор

Не разрешается связывать с одним физическим файлом более одной файловой переменной.

2.После окончания работы с файлами на Паскале, они должны быть закрыты.

     Close(<список файловых переменных>);

При выполнении этой процедуры закрываются соответствующие физические файлы и фиксируются сделанные изменения. При выполнении процедуры close связь файловой переменной с именем дискового файла, сохраняется, следовательно, файл можно повторно открыть без дополнительного использования процедуры assign.

Работа с файлами заключается, в основном, в записи элементов в файл и считывании их из файла. Для удобства описания этих процедур введем понятие указателя. Указатель – маркер определяющий позицию доступа, т.е. ту позицию файла, которая доступна для чтения (в режиме чтения), либо для записи (в режиме записи).


школа №9"

г. Таштагол

МАССИВ — это УПОРЯДОЧЕННАЯ последовательность данных
ОДНОГО ТИПА.

Массивы (табличные данные ) относятся к так называемым структурированным данным, то есть данным, которые составляются из других типов данных.

Для того чтобы описать массив, необходимо задать тип компонента и тип индекса.

Существуют:

а) линейные массивы;

б) двумерные массивы.

Линейным (одномерным) массивом можно назвать совокупность

одинаковых компонентов, имеющих один индекс.

Описание такого массива может быть выполнено двумя способа-

ми:

1. через введение типа данных пользователя:

Type наименование типа = array [ диапазон индекса] of тип компонента;

Var имя массива: наименование типа;

Например:

Type mass = array [1..10] of real;

 Var f:mass;

 2. Var a:array [1..5] of integer;

Заполнение массива

Заполнение массива можно производить:

•с клавиатуры;
•через датчик случайных чисел;
•через оператор присваивания (по формуле)

Пример. Поиск элементов с заданными свойствами.

Заполнить одномерный массив 50 целыми случайными числами из промежутка [-200;200], определить:

а) сумму всех элементов;
б) сумму отрицательных чисел;
в) количество чисел кратных 5.

Program Poisk;

     Var а:array[1..50] of integer;  i,S,S1,n: integer;

   Begin

  {заполнение массива}

       For i:=1 to 50 do begin

       a[i]:=random(400)-200;

       write(a[i]:8);

       end;

{сумма всех элементов}

   S:=0;

       For i:=1 to 50 do

       S:=S+ a[i];

       writeln(‘сумма всех элементов S=',S);

{сумма отрицательных чисел}

S1:=0;

    For i:=1 to 50 do

       if a[i]<0 then S1:=S1+ a[i];

       writeln(‘сумма отрицательных чисел S1=',S1);

    {количество чисел кратных 5}

n:=0;

   For i:=1 to 50 do

        if a[i] mod 5=0 then n:=n+1;

        writeln(‘количество чисел кратных 5= ',n);

   End.

Результат выполнения программы:


школа №9"

г. Таштагол

Стандартные операции и функции Паскаля

Стандартные арифметические операции

Условный знак | Выражение | Название операции | Тип переменных в выражении | Тип результата выполнения операции
* | x*y | Умножение | целый, вещественный | целый при операции с целыми числами, иначе вещественный
/ | x/y | Деление | с мешанный вещественный | вещественный
div | N div M | Деление | ц елый | ц елый
mod | N mod M | Остаток от деления | ц елый | ц елый
+ | x + y | Сложение | целый, вещественный | целый при операции с целыми числами, иначе вещественный

Стандартные математические операции

 | тип аргумента | тип результата | название операции
abs(x) | Целый вещественный | Целый вещественный | абсолютное значение "x"
sin(x) | Вещественный | Вещественный | синус "х", (х в радианах)
cos(x) | Вещественный | Вещественный | косинус"x", (х в радианах)
arctan(x) | Вещественный | Вещественный | арктангенс "х"
Sqrt(x) | вещественный | вещественный | квадратный корень из "х"
Sqr(x) | Целый вещественный | Целый вещественный | значение "х" в квадрате
Exp(x) | вещественный | вещественный | значение "е" в степени "х" ( где e=2,72 )
Ln(x) | вещественный | вещественный | натуральный логарифм "х" ( х > 0 )
Frac(x) | вещественный | вещественный | дробная часть "х"
Int(x) | Вещественный | Вещественный | целая часть "х"
Random | - | вещественный | случайное число ( 0 < =y< 1 )
Random(x) | Word | Word | случайное число ( 0 < =y< x )
Succ(c) | Порядковый | Порядковый | следующий за "с" символ
Pred(c) | Порядковый | Порядковый | предшествующий "с" символ

Логические операции

Приоритет операции | Условный знак | Выражение | Название операции | Тип переменных в выражении | Тип результата выполнения операции
 |  |  | ЛОГИЧЕСКИЕ ОПЕРАЦИИ
1 | not | not A | Логическое "не" | Логический целый | Логический целый
2 | and | A and b | Логическое "и" | Логический целый | Логический целый
3 | or | A or B | Логическое "или" | Логический целый | Логический целый
3 | xor | A xor B | Логическое исключающее "или" | Логический целый | Логический целый
 |  |  | ОПЕРАЦИИ СРАВНЕНИЯ
4 | = | x=y | Равно | Число=число | Логический
4 | <> | X<>y | Не равно | Строка=символ | Логический
4 | > | x>y | Больше | Строка=символ | Логический
4 | < | x<Y< td> | Меньше | Строка=символ | Логический
4 | >= | x>=y | Больше или равно | Строка=символ | Логический
4 | <= | x<=y | Меньше или равно | Строка=символ | Логический


школа №9"

г. Таштагол

Применение оператора цикла

While

Вычислить сумму квадратов нечетных чисел от 1 до 11

Repeat

Вычислить сумму квадратов нечетных чисел от 1 до 11

For

Вычислить факториал числа(n!), n вводится с клавиатуры


школа №9"

г. Таштагол

Подпись: В Паскале нет возведения в степень. При составлении программ можно использовать формулу перехода от степенной функции к показательной pn=en ln p Например: p5 -> exp(5*ln(p))

Вычислить значение выражения при х=5, у=7


школа №9"

г. Таштагол

Вычислить количество <r> в строке


школа №9"

г. Таштагол

Для символьных переменных - применение типа char существуют стандартные функции:

Ord(s) - выдает номер символа s в кодовой таблице ASCII;

Chr(n) - выдает символ по его коду n в кодовой таблице ASCII;

Upcase(s) - значением является большая буква s; действует только для английских букв.

Значение переменной типа char может быть буква, символ, цифра, специальные символы.


Новая страница 1

МОУ

школа №9"

г. Таштагол

На главную

Структура программ на Паскале

Все программы на Паскале имеют строгую структуру и состоят из четырёх разделов.


школа №9"

г. Таштагол

На главную

Классификация типов данных:

Тип данных определяет свойства описываемой величины: форму её внутреннего представления, множество принимаемых значений, множество допустимых операций, объём занимаемой памяти.

Идентификатор | Длина, байт | Диапазон (множество) значений
Целые типы
Integer | 2 | -32768…32767
Byte | 1 | 0…255
Word | 2 | 0…65535
Shortint | 1 | -128…127
Longint | 4 | -2147483648…2147483647
Вещественные типы
Real | 6 | 2,9 .10 -39 …1,7 . 1038 (11-12)
Single | 4 | 1,5 .10 -45 …2,3 . 1038 (7-8)
Double | 8 | 5 .10 -324 …1,7 . 10308 (15-16)
Extended | 10 | 3,4 .10 -4932 …1,1 . 104932 (19-20)
Логический тип
Boolean | 1 | True, False
Символьный тип
Char | 1 | Все символы кода ASCII


школа №9"

г. Таштагол

Оператор выбора Case

Иногда бывает необходимо, чтобы некоторая часть программы была выполнена, если справедливо некоторое заданное условие. В Паскале реализуется это с помощью условных операторов if и case.

if выбирает одно из двух возможных вариантов

case - одно из нескольких действий.

Условный оператор может быть записан в полной и неполной формах

Подпись: Полная форма: if условие then оператор 1 else оператор 2 Подпись: Неполная форма:   if условие   then оператор


школа №9"

г. Таштагол

Любой файл имеет три характерные особенности. Во-первых, у него есть имя, что дает возможность программе работать одновременно с несколькими файлами. Во-вторых, он содержит компоненты одного типа. Типом компонентов может быть любой тип Паскаля, кроме файлов. Иными словами, нельзя создать «файл файлов». В-третьих, длина вновь создаваемого файла никак не оговаривается при его объявлении и ограничивается только емкостью устройств внешней памяти.

Способы описания файловых переменных:

         1.
        Type <имя_ф_типа>=file of<тип_элементов>;
2. <имя_ф_типа>=text;
3. <имя_ф_типа>=file;

Здесь <имя_ф_типа> – имя файлового типа (правильный идентификатор); File, of – зарезервированные слова (файл, из); <тип_элементов> – любой тип Паскаля, кроме файлов.

В зависимости от способа объявления можно выделить три вида файлов Паскаля:

· типизированные файлы Паскаля(задаются предложением file of..);

· текстовые файлы Паскаля(определяются типом text);

· нетипизированные файлы Паскаля(определяются типом file).

Далее->


школа №9"

г. Таштагол

В большинстве задач многократное повторение действий может быть задано оператором цикла (повторения).

Turbo Pascal поддерживает три классических управляющих конструкции:

а) Цикл с предусловием While,

б) Цикл с постусловием Repeat,

в) Цикл со счетчиком For.

Цикл While. Является универсальным циклом.

Цикл Repeat

Цикл For